LibertyBans

LibertyBans

Plugin

Obedience is liberating

Server ManagementUtility

1,235 downloads
32 followers
Created2 years ago
Updated2 months ago

Follow Save
Host your Minecraft server on BisectHosting - get 25% off your first month with code MODRINTH.

1.0.4

Changelog

Hereafter, LibertyBans supports the Sponge platform, API versions 8 and above. This development, we hope, will extend the usability of LibertyBans. Deployable in many varieties of environments yet utilizing common code, LibertyBans has always been designed to support multiple platforms. The Sponge API is the natural continuation of this impetus.

Moreover, we have solved, by a clever exploit, the longstanding issue which made LibertyBans vulnerable to bugs in other plugins. Specifically, unrelocated libraries in other plugins will no longer affect LibertyBans. We will continue to recommend you to fix these bugs, because your server's stability is our concern too. However, LibertyBans will be able to proceed despite these situations.

Bugs fixed:

  • Fixed an embarrasing bug which caused importing from BanManager to be impossible, since /libertybans import banmanager was not recognized
  • Updated database revision per previous change in 1.0.3

Feature additions:

  • Sponge support. API 8 and API 9 are supported
  • The checkuser addon provides the /checkuser command, thanks to SnakeAmazing. This addon displays whether a user has an applicable ban or mute
  • The LibertyBans/internal/attachments folder allows attaching driver jars, which is useful for importing from LiteBans H2

Other:

  • Protect classloading from unrelocated libraries, by filtering classes requested in parent classloader
  • The hypersql/ and libraries/ folders are moved under LibertyBans/internal. Existing directories will be migrated automatically

Files

LibertyBans_Release-1.0.4.jar(231.55 KiB) Primary Download

External resources



Project members

A248

Owner

KoxSosen

Member


Technical information

License
AGPL-3.0-or-later
Project ID