OptiGUI

OptiGUI

Mod

Blazing fast custom GUI textures on Fabric and Quilt with built-in OptiFine custom GUI resource pack support

Client DecorationUtility

1.55M downloads
631 followers
Created2 years ago
Updateda month ago

Follow Save
Host your Minecraft server on BisectHosting - get 25% off your first month with code MODRINTH.
Filter loader...
Filter versions...
Filter channels...

OptiGUI 2.3.0-beta.2+1.20.5

This is a port of OptiGUI 2.3.0-beta.2 to Minecraft 1.20.5. See OptiGUI 2.3.0-beta.2 changelog.

OptiGUI 2.3.0-beta.2

Where's 2.3.0-beta.1?

It was removed due to incompatibilities with Minecraft 1.20.5.

What's new since 2.3.0-alpha.2

  • Support for Minecraft 1.20.5
    • Block entity NBT is not available in the inspector on this version

What changed since 2.3.0-alpha.2

  • Fix villager.type selector

About this release

  • This version will refuse to load on Minecraft 1.20.5. A separate JAR for Minecraft 1.20.5 will be released later.
  • Recommended for everyday users
  • Recommended for modpacks
  • Automatic selector tests are work in progress, and will be implemented later, before the full 2.3.0 release
    • If you find a selector, which doesn't work, please open an issue about it
  • Check out the documentation, now on a new domain!

OptiGUI 2.3.0-alpha.2

This version of OptiGUI is based on OptiGUI 2.1.3, not OptiGUI 2.2.0-alpha.1.

What changed since 2.2.0-alpha.1

OptiGUI 2.2.x codebase was highly experimental, but I ended up not liking it, so I reverted it with the exception of the following:

  • Filter load priority (load.priority)
  • Selectors interaction.hand, horse.has_saddle, horse.variants, horse.markings, llama.variants
  • Inspector
  • Some internal and utility enhancements
  • Texture replacer optimizations

What changed since 2.1.3 and 2.2.0-alpha.1

  • Drop support for Minecraft 1.20.1 and older versions. I have no motivation to support binary incompatible Minecraft versions
    • Remove OptiGlue
    • LiLaC is no longer a dependency
  • Rework the codebase
    • Remove tech debt from supporting multiple, binary incompatible Minecraft versions
    • This introduces breaking API changes for developers
    • This also made the code smaller, and enabled some more optimizations in the texture replacer
  • Make adding 3rd party containers simpler, and more compatible with builtin OptiGUI selectors

Recommendations

  • Recommended for individuals, who like testing (and breaking) stuff
  • Recommended to try for resource pack creators (please create a new profile)
  • Not recommended for everyday users
  • Not recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.1.7

What's new since 2.1.6

  • Add support for Minecraft 1.20.3 and 1.20.4

About this release

  • This release is based on the legacy 2.1.5 codebase, and only has minimal changes
  • The code is available on the legacy/2.1.7 branch, and will not be merged into the main branch
    • The tag is also on the legacy/2.1.7 branch instead of the usual main

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages
  • Quilt users, please wait for the next Quilt Loader update

OptiGUI 2.1.6

What's new since 2.1.5

  • Add support for Minecraft 1.20.2
  • Add support for trader llamas (I missed this earlier)

About this release

  • This release is based on the legacy 2.1.5 codebase, and only has minimal changes
  • The code is available on the legacy/2.1.6 branch, and will not be merged into the main branch
    • The tag is also on the legacy/2.1.6 branch instead of the usual main

Why did it take so long?

See #75.

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.2.0-alpha.1 developer preview

What's new since 2.1.5

  • Refactor codebase
  • Extend API for 3rd party mods
    • Split API JAR from main JAR
  • Huge performance improvements
    • Significantly reduce allocations while evaluating filters
    • Significantly reduce allocations while a supported GUI screen is open
  • Inspector for resource pack creators (default keybind is F12)
  • Add new selectors (will update the documentation)
  • Fix trader llama bug

About this release

  • Extract and repurpose bundled OptiGlue to LiLaC (new dependency)
  • This is the first developer preview of 2.2.0
  • For other mod developers: the API will likely change in the alpha phase
  • This release doesn't include every planned 2.2.0 feature
  • I kinda rushed releasing it, but didn't
    • A good amount of changes have been made, and I'm happy releasing them
    • The development pace will be slower from now on, because I have a life outside Minecraft

Recommendations

  • Recommended for individuals, who like testing (and breaking) stuff
  • Recommended to try for resource pack creators (please create a new profile)
  • Not recommended for everyday users
  • Not recommended for modpacks
  • Documentation is available on GitHub Pages
    • Outdated as of releasing this version, but will update it soon (1-2 weeks from now)

OptiGUI 2.1.5

What's new since 2.1.4

  • Fixed a crash on Minecraft 1.19.2 and lower caused by hanging sign support (again)

About this release

  • This is another hotfix release for 2.1.3 (and 2.1.4)

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.1.4

What's new since 2.1.3

  • Fixed a crash on Minecraft 1.19.2 and lower caused by hanging sign support

About this release

  • This is a hotfix release for 2.1.3
  • Still broken on 1.19.2 and earlier

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.1.3

What's new since 2.1.2

  • New selectors
    • donkey.has_chest
    • comparator.output
    • villager.type
    • book.page.current
    • book.page.count
  • Book support
  • Hanging sign support

About this release

  • This is the last 2.1.x release before a partial rewrite and code cleanup in 2.2.0
  • More selectors are planned to be added in 2.2.1 after a ✨shiny new feature✨
  • Bug fixes are planned for 2.2.0
  • Broken on 1.19.2 and earlier

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.1.2

What changed since 2.1.1

  • Add Minecraft 1.20.1 support

About this release

  • Quilt has updated
    • Fabric loader version in fabric.mod.json has been set to the one in gradle.properties

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.1.1

What changed since 2.1.0

  • Fix a bug, which potentially results in loading a resource multiple times
  • Set required Fabric Loader to 0.14.19 in fabric.mod.json

About this release

  • This is a hotfix release for 2.1.0 to let Quilt users play

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.1.0

What's new

  • Minecraft 1.20 support
  • Basic lectern support

What changed since 2.1.0-beta.3

  • Optimize resource loading
    • Fix resource leak

What changed since 1.1.6

  • One JAR supports Multiple Minecraft versions
  • Official Quilt support
  • Rewritten in Kotlin
  • New OptiGUI ini format
    • More ways to replace GUI textures
  • Support for Minecraft 1.19.4 and 1.20
  • Basic support for almost all GUIs
    • Upcoming: hanging signs
    • Upcoming: more selectors
  • Removed _extensions from OptiFine properties
    • Added to OptiGUI ini files
    • See documentation for migration guide
  • Use filter chain instead of in-memory representation of files
  • New icon
  • Documentation

About this release

  • This is the first stable version after 6 months of development and Java+Gradle+Loom+IntelliJ breakage
    • Some alpha and beta builds were pretty stable tho
  • There's a lot more features to come
  • If you have an idea how OptiGUI should be expanded, you can open an issue on GitHub

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.1.0-beta.3

What changed since 2.1.0-beta.2

  • Remove a phantom warning in OptiFine converter when texture is missing
    • If only texture.<path> is present, which is valid, this no longer shows
  • Add basic conditional loading of individual resources. See documentation
  • OptiGUI and OptiGlue library depend on each other in fabric.mod.json
    • Fabric will not launch if either is missing for some reason
    • Instead of crashing with an "Error loading OptiGlue" exception

About this release

  • This is the last beta for 2.1.0, unless significant problems arise
  • The next release will be the full release after Minecraft 1.20
    • It will include 1.20 support (the current build has no OptiGlue marked as 1.20-compatible)

Recommendations

  • Recommended for everyday users
  • Recommended for modpacks
  • Documentation is available on GitHub Pages

OptiGUI 2.1.0-beta.2

What changed since 2.1.0-beta.1

  • Fixed crashes on older Quilt

About this release

  • Should be stable enough for daily driving

Recommendations

  • Recommended for everyday users
  • Modpacks may decide to wait till the full release
  • For other mod developers:
    • Fundamental API changes are unlikely, but breaking changes may be introduced till the full release
    • Documentation is available on GitHub Pages

OptiGUI 2.1.0-beta.1

Where is 2.0.0 full release?

Nowhere. The code was a bit buggy, and I reworked the properties in #32 in the meanwhile. This introduced a breaking change in resource packs, so I decided to skip the full release, and ship the next beta (with an increased version number).

What's new

What changed since 2.0.0-beta.3

  • Fix crashes on older (than 1.19.4) Minecraft versions
  • Increased extensibility for other mods
  • Improved performance
  • Better ModMenu integration
  • Fix smithing table GUI

About this release

  • Should be stable enough for daily driving

Recommendations

  • Recommended for everyday users
  • Modpacks may decide to wait till the full release
  • For other mod developers:
    • Fundamental API changes are unlikely, but breaking changes may be introduced till the full release
    • Documentation is available on GitHub Pages

OptiGUI 2.0.0-beta.3

What's new

  • Basic support for pre-1.20 smithing table GUI
    • This doesn't take into account the 1.20 data pack
    • The texture to be replaced cannot be checked as of now

What changed since 2.0.0-beta.2

  • Breaking changes for developers:
    • Removed Jitpack support (use Modrinth Maven or CurseMaven)
    • Triggernig non-block-entity container GUI replacement from 3rd party mods is now supported
    • Remove container and texture from GeneralProperties and subclasses

About this release

  • Should be stable enough for daily driving

Recommendations

  • Recommended for everyday users
  • Modpacks may decide to wait till the full release
  • For other mod developers:
    • Fundamental API changes are unlikely, but breaking changes may be introduced till the full release
    • Documentation is available on GitHub Pages

OptiGUI 2.0.0-beta.2

What's new

  • Fixed Minecraft 1.19.4 support (#24)

What changed since 2.0.0-beta.1

  • Breaking changes for developers:
    • Change JVM name of PathResolverKt to PathResolver
    • Change JVM name of VillagerProfessionParserKt to VillagerProfessionParser

About this release

  • Should be stable enough for daily driving (even for Minecraft 1.19.4)

Recommendations

  • Recommended for everyday users
  • Modpacks may decide to wait till the full release
  • For other mod developers:
    • The API is not likely to change till the full release
    • Documentation is available on GitHub Pages

OptiGUI 2.0.0-beta.1

What's new

  • Add support for llama carpet color
  • Add name as player name in container=inventory
  • Optimize texture replacer code with cache
    • Please note that you may still get a lag spike when interacting with a container for the first time, because Java.

About this release

  • This is the first beta of OptiGUI 2.0.0, and should be stable enough for daily driving
  • Turns out that Minecraft 1.19.4 is incompatible (#24)

Recommendations

  • Recommended for everyday users
  • Modpacks may decide to wait till the full release
  • For other mod developers:
    • The API is not likely to change till the full release
    • Documentation will soon be available on GitHub Pages

OptiGUI 2.0.0-alpha.6 development build

What's new

  • Minecraft 1.19.4 support (broken)
  • Chest boat support (this broke 1.18-1.19.2 support)

What changed since 2.0.0-alpha.5

  • Remove javadoc from Jitpack. It will be added to the project's future GitHub page.

About this release

  • The first beta is planned to be similar to this release with minor changes
  • See details and future plans here

Recommendations

  • Recommended for individuals, who like testing (and breaking) stuff
  • Not recommended for everyday users
  • Not recommended for modpacks
  • For other mod developers: the API will likely change in the alpha phase

OptiGUI 2.0.0-alpha.5 development build

What's new

  • Added support for Quilt
  • Added support for chest minecarts
  • Added support for hopper minecarts
  • Added some modularity and new APIs for mod developers

What changed since 2.0.0-alpha.4

  • Revert mappings change
  • A lot of breaking changes caused by refactoring

About this release

  • The first beta is planned to be similar to this release with minor changes
  • See details and future plans here

Recommendations

  • Recommended for individuals, who like testing (and breaking) stuff
  • Not recommended for everyday users
  • Not recommended for modpacks
  • For other mod developers: the API will likely change in the alpha phase

External resources



Project members

opekope2

Owner


Technical information

License
MIT
Client side
required
Server side
unsupported
Project ID